【Perl】 インストールされているモジュールのバージョンを調べるワンライナー

この記事は9年以上前に書かれたものです。 情報が古い可能性があります。

マシンにインストールされているPerlモジュールのバージョンを調べる方法として、今までよくやっていたのが、

という方法でしたが、

のように、バージョン999を指定してuseし、わざとコンパイルエラーを出力させる、という方法もあるみたいです(こちらで知りました…)。この方がタイピングの量が圧倒的に少なくて済みますね。目からウロコです…


ご意見やお問い合わせについて

この記事へのご意見やお問い合わせについては、こちら(お問い合わせフォーム)もしくは
Hinemos営業担当【hsd-sales@atomitech.jp】までご連絡ください。

※お問い合わせフォームからご連絡の場合には、お問い合わせ内容で「Hinemosについて」を選択し、
 本文の冒頭に「Hinemos研究日記_【タイトル名】」とご記載ください。
※メールアドレスへご連絡の場合には、件名を「Hinemos研究日記_【タイトル名】」でご連絡ください。